Data/Callsign Database Upgrade

Jim1348
Posts: 17
Joined: Thu Feb 28, 2019 5:38 pm

Data/Callsign Database Upgrade

Post by Jim1348 » Fri Apr 12, 2019 12:25 am

I got my OpenSpot 2 a few weeks ago, but today is the first day have done anything with it. I was able to upgrade the firmware, but when I try to upgrade the Data/Callsign Database it apparently fails. Does anybody have any ideas what I should do to fix this issue?

Perhaps I am overthinking this, however. Is it possible that it will update overnight on its own?

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 4409
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Data/Callsign Database Upgrade

Post by HA2NON » Fri Apr 12, 2019 5:05 am

It will automatically update everything.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

Jim1348
Posts: 17
Joined: Thu Feb 28, 2019 5:38 pm

Data/Callsign Database Upgrade

Post by Jim1348 » Fri Apr 12, 2019 3:06 pm

It still displays:

Data upgrade available!


Available upgrades
Data / callsign database:
201904080908
(stable version, 3.69 MB)

When I try it displays:

Downloading callsign database... (0%)

Then I get this:

Callsign database upgrade download failed

Does anybody here know what else I should try?

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 4409
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Data/Callsign Database Upgrade

Post by HA2NON » Fri Apr 12, 2019 5:49 pm

What does the device log show on the Status page?
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

Jim1348
Posts: 17
Joined: Thu Feb 28, 2019 5:38 pm

Data/Callsign Database Upgrade

Post by Jim1348 » Fri Apr 12, 2019 9:47 pm

16:46:18 httpsrv[0]: websocket opened with token 2876deaa
16:46:18 httpsrv[0]: websocket opened with token 2876deaa
16:46:18 spk: sending terminator
16:46:18 nvmm-csd: looking up id 9 type 0
16:46:18 nvmm-csd: no csd
16:46:18 spk: starting voice announcement
16:46:19 spk: requesting remote play: OSCTHBSV
16:46:19 spk-remote: got first packet
16:46:19 nvmm-csd: looking up id 9 type 0
16:46:19 nvmm-csd: no csd
16:46:23 homebrew: ping sent
16:46:23 homebrew: pong received
16:46:24 spk: sending terminator
16:46:24 spk: remote disconnected
16:46:24 nvmm-csd: looking up id 9 type 0
16:46:24 nvmm-csd: no csd
16:46:27 nvmm: net check
16:46:27 nvmm: net check ok (66 ms)
16:46:29 homebrew: ping sent
16:46:29 homebrew: pong received
16:46:36 homebrew: ping sent
16:46:36 homebrew: pong received
16:46:42 homebrew: ping sent
16:46:42 homebrew: pong received
16:46:49 homebrew: ping sent
16:46:49 homebrew: pong received
16:46:55 homebrew: ping sent
16:46:55 homebrew: pong received
16:47:01 homebrew: ping sent
16:47:01 homebrew: pong received
16:47:07 homebrew: ping sent
16:47:07 homebrew: pong received
16:47:13 homebrew: ping sent
16:47:13 homebrew: pong received

Jim1348
Posts: 17
Joined: Thu Feb 28, 2019 5:38 pm

Data/Callsign Database Upgrade

Post by Jim1348 » Fri Apr 12, 2019 11:46 pm

I did a factory reset and now I can't even connect to it. I have tried on a smartphone, tablet and laptop computer.

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 4409
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Data/Callsign Database Upgrade

Post by HA2NON » Sat Apr 13, 2019 5:10 am

The log you've inserted does not contain any information about the download process. Look for lines starting with "httpcln:"

What LED color do you see on the device?
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

Jim1348
Posts: 17
Joined: Thu Feb 28, 2019 5:38 pm

Data/Callsign Database Upgrade

Post by Jim1348 » Sun Apr 14, 2019 4:36 pm

I have been trying various things this weekend to get this to work. I have posted this on Facebook. The problem is, once it is in the "openSPOT2 AP" mode, it will lose the connection. I have the Shark OpenSpot 2 just a few inches from my computer and it does have a strong signal, when it does connect, but it won't stay connected.

How should I proceed?



https://www.facebook.com/groups/OpenSpo ... up_comment

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 4409
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Data/Callsign Database Upgrade

Post by HA2NON » Mon Apr 15, 2019 5:47 am

While the openSPOT2 is in AP mode, it can't reach the internet. It only broadcasts it's own Wi-Fi network called "openSPOT2 AP" for the initialization setup.

Please note that we don't monitor any Facebook groups, as official support is only available in email at info@sharkrf.com and here on this forum.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

Jim1348
Posts: 17
Joined: Thu Feb 28, 2019 5:38 pm

Data/Callsign Database Upgrade

Post by Jim1348 » Mon Apr 15, 2019 10:14 am

It won't stay connected in the AP mode.

Post Reply