Page 1 of 1

Cannot connect to vehicle Onstar Wifi network

Posted: Sat Jun 27, 2020 9:33 pm
by Dhewet1
My OS2 has worked perfectly on my home wifi networks since the day I received it, but after many attempts, I can not get it to connect to my vehicle's Onstar WiFi network. When I go into AP mode and run an initial setup, the OS2 does see the Onstar net work when it runs the wireless network scan. After I select the Onstar wifi network, it will flash blue but is never able to connect. It quickly connects to all of my home networks and will easily connect to my Andoid cell phone's hot spot.

I can connect all of my other wireless devices to the Onstar WiFi without fail.

The Onstar network is ATT and they are using WPA2 security and the network channel is 11.
It seems like they are blocking the OS2 with a firewall but I am just guessing :?

I have opened a high level tech support ticket with OnStar but I am not very optimistic that they will have an answer.

Any clues or suggestions?
Thanks, David WA5TXY

Re: Cannot connect to vehicle Onstar Wifi network

Posted: Sun Jun 28, 2020 12:40 pm
by Tyrbiter
If you have a laptop you could try capturing the WiFi negotiation using Wireshark. Might give you a clue what is happening if you can get sensible packet traces.

Re: Cannot connect to vehicle Onstar Wifi network

Posted: Sun Jun 28, 2020 3:33 pm
by Dhewet1
Brian, Thanks for the reply and suggestion regarding Wireshark. I will download that tool and hopefully learn how to use it next week. 73!

Re: Cannot connect to vehicle Onstar Wifi network

Posted: Mon Jun 29, 2020 8:03 am
by HA2NON
If you can, try switching the Onstar Wi-Fi channel or Wi-Fi bandwidth.