initial setup will not connect to my wifi

rbleslie
Posts: 7
Joined: Wed Sep 23, 2020 8:15 pm
Location: USA

initial setup will not connect to my wifi

Post by rbleslie »

I've tried at least 20 times, using iphones, ipads, laptop, desktop, and android tablet.

I can never get the alternating green/yellow (or green) status, so my UID is not found.


As soon as I enter my wifi password, i get a slow blinking blue light

I've tried, chrome, firefox, safari, microsoft edge and IE.

This should be straight forward. What am I missing?

I don't see a "re-run initial setup button on the Quick Setup Page. Maybe that's what I'm missing?

Additionally: router is on channel 6 and bandwidth is fixed at 20Mhz. encryption is WPA2 and I made sure i am using 2.4 GHZ--not 5GHZ. The sharkrf is as close the the router as it can get.
Tyrbiter
Posts: 671
Joined: Thu Dec 22, 2016 11:25 pm

Re: initial setup will not connect to my wifi

Post by Tyrbiter »

Which router do you have?
Brian G8SEZ
rbleslie
Posts: 7
Joined: Wed Sep 23, 2020 8:15 pm
Location: USA

Re: initial setup will not connect to my wifi

Post by rbleslie »

Askey - Model RAC2V1K provided by Spectrum
User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5458
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: initial setup will not connect to my wifi

Post by HA2NON »

Please do the following:

- You can reconfigure the Wi-Fi connection if you switch back the openSPOT3 to access point mode by pressing the Wi-Fi button for 3 seconds.
- The openSPOT3 will start broadcasting it's own Wi-Fi network called "openSPOT3 AP", indicated by white LED. You can connect to this network using your browser device (phone/tablet/computer). Make sure you place your phone/tablet/computer close to the openSPOT3 during this time. The initialization setup will pop up, where you can select the country of operation and configure a Wi-Fi network for the openSPOT3 to connect to.
- Make sure you've entered the Wi-Fi password case sensitive.
- After you've chosen the Wi-Fi network and entered the password, the openSPOT3 stops broadcasting it's own Wi-Fi network and starts connecting to the selected network. At that moment, your browser device (phone/tablet/computer) will disconnect from the openSPOT3's network. What you have to do now is to connect to the exact same Wi-Fi network with your browser device as you've configured for the openSPOT3, and then use sharkrf.link to open the web interface.
- If you have WEP encryption on your router, then make sure the password is ASCII, not hex. The openSPOT3 only supports ASCII WEP passwords. The best is to switch the encryption to WPA2 or WPA because it's much safer.
- Make sure you have enabled 2.4GHz Wi-Fi, not just 5GHz.
- Place the openSPOT3 close to the Wi-Fi router.
- Make sure the Wi-Fi bandwith is set to max. 20Mhz in the Wi-Fi router (see explanation here: https://superuser.com/questions/542191/ ... less-speed)
- If it still does not work, try switching Wi-Fi channel on your Wi-Fi router. Only channels 1, 6 or 11 should be used (see explanation here: https://www.metageek.com/training/resou ... -6-11.html)
Norbert Varga, HA2NON
SharkRF Team
Tyrbiter
Posts: 671
Joined: Thu Dec 22, 2016 11:25 pm

Re: initial setup will not connect to my wifi

Post by Tyrbiter »

rbleslie wrote: Wed Sep 23, 2020 11:42 pm Askey - Model RAC2V1K provided by Spectrum
I had a quick look and can't see any major problems, but I did see someone suggesting that they resolved problems by disabling IPv6 on the router, maybe that would be worth a try.
Brian G8SEZ
rbleslie
Posts: 7
Joined: Wed Sep 23, 2020 8:15 pm
Location: USA

Re: initial setup will not connect to my wifi

Post by rbleslie »

I've tried this again multiple times.
I verified that
- my router channel is 6
- I am using 2.4 ghz and not 5 ghz
- I am typing my password correctly; i display it so that i make sure it is correct
- i am using WPA2
- the OS3 is 6 inches from my router.
- after I enter the password, I don't do anything until the sharkrf.link page goes blank and say no connection

Still have the same problem. As soon as I enter the password, OS3 goes to a blue slow-blinking light and never connects to my wifi.

I did try disabling IPv6 (and resetting the modem) and still get the same result.
Tyrbiter
Posts: 671
Joined: Thu Dec 22, 2016 11:25 pm

Re: initial setup will not connect to my wifi

Post by Tyrbiter »

Might be worth increasing the distance to a few feet away just to be sure it's not down to receiver overload in the OS3 WiFi module.

Any fw updates available for your router? Worth checking that too.
Brian G8SEZ
N1IG
Posts: 52
Joined: Thu Apr 09, 2020 7:50 pm

Re: initial setup will not connect to my wifi

Post by N1IG »

rbleslie wrote: Thu Sep 24, 2020 2:25 pm
...
Still have the same problem. As soon as I enter the password, OS3 goes to a blue slow-blinking light and never connects to my wifi.

...

Silly question, but does your router have MAC address filtering of some sort, and only allows MAC addresses that have been set in it's admin settings?
rbleslie
Posts: 7
Joined: Wed Sep 23, 2020 8:15 pm
Location: USA

Re: initial setup will not connect to my wifi

Post by rbleslie »

I will find out about router updates. In the mean time, I checked the router log to see if there was an indication that the OS3 was trying to connect. I see this:

The first line is my OS3 MAC address: e8:2a:44:51:b0:d1

Thu Sep 24 09:04:54 2020 daemon.info hostapd: ath1: STA e8:2a:44:51:b0:d1 IEEE 802.11: associated
Thu Sep 24 09:04:54 2020 kern.warn kernel: [ 4025.124091] ATM is re-allocating airtime because e8:2a:44:51:b0:d1 is now active
Thu Sep 24 09:04:54 2020 daemon.info hostapd: ath1: STA e8:2a:44:51:b0:d1 RADIUS: starting accounting session 034E288B826F263A
Thu Sep 24 09:04:54 2020 daemon.info hostapd: ath1: STA e8:2a:44:51:b0:d1 WPA: pairwise key handshake completed (RSN)
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4025.594473] [wifi1] FWLOG: [3554248] RATE: ChainMask 1, peer_mac b0:d1, phymode 5, ni_flags 0x00201806, vht_mcs_set 0x0000, ht_mcs_set 0x00ff, legacy_rate_set 0x0ff0
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4025.608649] [wifi1] FWLOG: [3554285] WAL_DBGID_SECURITY_UCAST_KEY_SET ( 0xb0d1, 0x0 )
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4025.616018] [wifi1] FWLOG: [3554285] WAL_DBGID_SECURITY_ENCR_EN ( )
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4025.622352] [wifi1] FWLOG: [3554285] WAL_DBGID_SECURITY_ALLOW_DATA ( 0x457f00 )
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4026.133609] client 00:03:7f:2b:64:be connected to SSID Others has 16% airtime
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4026.139799] client 80:c5:f2:a6:a4:59 connected to SSID Others has 16% airtime
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4026.146900] client 00:26:ab:b9:df:e4 connected to SSID Others has 16% airtime
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4026.154022] client cc:6d:a0:b0:20:17 connected to SSID Others has 16% airtime
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4026.161059] client d8:31:34:d7:3c:13 connected to SSID Others has 16% airtime
Thu Sep 24 09:04:55 2020 kern.warn kernel: [ 4026.168236] client e8:2a:44:51:b0:d1 connected to SSID Others has 16% airtime

The "connected to SSID" lines repeat every 30 seconds as long as I leave the OS3 on (blue light continues to blink slowly)
Tyrbiter
Posts: 671
Joined: Thu Dec 22, 2016 11:25 pm

Re: initial setup will not connect to my wifi

Post by Tyrbiter »

Can you see what IP address the router has allocated the OS3? If yes try connecting to that IP address and if you succeed you should be able to change the OS3 DNS override setting to on, it seems often that ISP DNS doesn't resolve things correctly and that stops the sharkrf.link server being contactable.
Brian G8SEZ
Post Reply