D-star repeater

af7l
Posts: 3
Joined: Fri Mar 03, 2017 11:19 pm

Re: D-star repeater

Post by af7l »

I have the 0108 firmware installed. I have set up a couple of D-Star memories to change repeater settings by Push-to-talk. Usually, I listen to REF030C with a connection to a local repeater which is linked to REF030C. So I set up a transceiver (ID-51A Plus) memory as shown below (with example repeater call):

Urcall: KA7AA..B [the ".." are two spaces]
R1: (blank)
R2: (blank)
Mycall: AF7L...A/OPST [the "... are three spaces]

When I PTT with this memory, the openSPOT changes to the B module of my local repeater just fine.
My other memory is set as follows so that I can change back to the C module:

Urcall: KA7AA..C
R1: (blank)
R2: (blank)
Mycall: AF7L...A/OPST

When I PTT with this memory, the openSPOT disconnects but does not reconnect successfully to the C module. Is there something that I am doing wrong? Thanks for your help.
Bruce, AF7L

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5284
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: D-star repeater

Post by HA2NON »

You can't connect because we don't have the gateway KA7AA in our gateway database, so openSPOT does not know what the IP address of KA7AA is. The source of our database list is http://www.va3uv.com/gwys.txt
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

af7l
Posts: 3
Joined: Fri Mar 03, 2017 11:19 pm

Re: D-star repeater

Post by af7l »

Thanks for your reply, Norbert. I'm sorry that I did not make it very clear - the call "KA7AA" was used only as an example (not real). I did not give the actual repeater call in my explanation. The actual call for the repeater IS in the database. As I noted in my explanation, the first PTT command worked just fine to change to module B. It was the second PTT which failed to work. The second PTT caused the openSPOT to disconnect from module B, but it did NOT reconnect to module C. Please take another look at my prior explanation and see if there is something wrong. Thank you.

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5284
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: D-star repeater

Post by HA2NON »

I was able to reproduce the issue, but this can't be fixed. openSPOT sends disconnect and connect packets correctly, but the server does not accept the new connection.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

af7l
Posts: 3
Joined: Fri Mar 03, 2017 11:19 pm

Re: D-star repeater

Post by af7l »

Thanks for checking it out, Norbert. I was wondering if I was just doing something without understanding important aspects. I guess that I do have a work-around. If I cannot reconnect to module C on my local repeater with a PTT call, then I can just connect to REF030C instead. My local repeater stays linked to REF030C continually, so at least I can still be tied in. Thanks again for your help.
Bruce, AF7L

Post Reply