Parrot not working

Post Reply
cgetty
Posts: 3
Joined: Tue Jun 13, 2017 2:58 am

Parrot not working

Post by cgetty »

Just got a new openSPOT. The good news is that it works very well. I can make contacts on TGs like TAC-310 and hear/monitor my calls on Hoseline. However, I can't get either Parrot (9990 or 9999) to work. The radio shows "Connecting" and then "Fail" after 5-10 seconds. Both are set up as Private calls. OpenSpot status page shows "TO: 9990" and FROM: My DMR ID." The OpenSpot status then immediately shows a return call "TO: My DMR ID and FROM: 9990". However, I don't hear anything. Using Brandmeister DMR. Any suggestions on how to get the Parrots to talk back to me? Thanks!
User avatar
K7CTC
Posts: 25
Joined: Thu May 11, 2017 11:09 pm

Re: Parrot not working

Post by K7CTC »

Congrats on the new openSPOT... It's a lot of fun.

"Connecting" and then "Call Failed"... It sounds like you do not have the "admit criteria" set correctly for your parrot channel in your code plug. It should be set to "admit always" or whatever the equivalent is in your programming software. This will force your transmission through without your radio waiting for "permission". It works similar to the BCLO or Busy Channel Lock Out on traditional FM rigs where if someone else is talking your PTT is locked to prevent you from stepping on them.

Under normal repeater operation both time-slots are typically used which enables bi-directional communication between the radio and repeater... This doesn't exist with the openSPOT under normal operation so there is no way for the openSPOT to "acknowledge" your attempt to get in. With a repeater, if you key up while the repeater is busy you will get call failed (or if you are out of range). If the repeater is open on the color code and time slot you will get an acknowledgement beep. At least that is how I understand it (and I could be wrong or over simplifying it).

But, I'm pretty sure if you check your admit criteria for the channel you have programmed for the parrot(s) you will see what I'm talking about.

Also, make sure the openSPOT isn't actively transmitting when you try to connect to parrot... This can occur if let's say you switch from a very active talk group over to the parrot channel on your rig and someone is still talking in that talk group... You won't hear them on your radio but your RX light will indicate if there is activity on the openSPOT frequency. You will either have to disconnect from the other talkgroup or wait until there is no modem activity on the openSPOT before keying the mic to get into the parrot TG.

73,
K7CTC (Chris)
User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5684
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Parrot not working

Post by HA2NON »

With the radios I've worked with - Hytera, Motorola, Tyt - you only need to modify the admit criteria if you use your radio in repeater mode, not simplex mode. DMR radios operate in simplex mode if both RX and TX frequencies are set to the same value. In simplex mode, the radio does not search for a repeater idle signal.

cgetty, make sure you have set the RX and TX frequencies to the same value, and your openSPOT's modem is in DMR Hotspot mode.
Norbert Varga, HA2NON
SharkRF Team
User avatar
K7CTC
Posts: 25
Joined: Thu May 11, 2017 11:09 pm

Re: Parrot not working

Post by K7CTC »

HA2NON wrote: Tue Jun 13, 2017 6:36 am make sure you have set the RX and TX frequencies to the same value.
Forgot to mention this... Thank you HA2NON. I wasn't aware that the radio ignored the admit criteria when in simplex. Learning something new each day is what this hobby is all about! :D

-K7CTC (Chris)
cgetty
Posts: 3
Joined: Tue Jun 13, 2017 2:58 am

Re: Parrot not working

Post by cgetty »

HA2NON wrote: Tue Jun 13, 2017 6:36 am With the radios I've worked with - Hytera, Motorola, Tyt - you only need to modify the admit criteria if you use your radio in repeater mode, not simplex mode. DMR radios operate in simplex mode if both RX and TX frequencies are set to the same value. In simplex mode, the radio does not search for a repeater idle signal.

cgetty, make sure you have set the RX and TX frequencies to the same value, and your openSPOT's modem is in DMR Hotspot mode.
HA2NON,

Yes RX and TX frequencies are the same (434.000/434.000) and the openSPOT modem is in DMR Hotspot mode. I was able to get the openSPOT Parrot (Echo mode) ID 9999 to work by changing this from private call to group call. Also, the Connect Query (ID 9998) and IP Address Query (ID 9001) both work when set as group calls. However, the Brandmeister Parrot (ID 9990) still gives me the same "Fail to Connect" message when set as a private call (which is needed). Maybe there some setting in openSPOT that I need to set or look at in order to send private calls? Somehow the private call feature isn't working I think.
User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5684
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Parrot not working

Post by HA2NON »

openSPOT's all service DMR IDs work both as a private and group call, so the issue is with your radio's configuration. I think you have the private call confirmed option turned on, please make sure it's turned off.
Norbert Varga, HA2NON
SharkRF Team
cgetty
Posts: 3
Joined: Tue Jun 13, 2017 2:58 am

Re: Parrot not working

Post by cgetty »

HA2NON wrote: Wed Jun 14, 2017 7:37 am openSPOT's all service DMR IDs work both as a private and group call, so the issue is with your radio's configuration. I think you have the private call confirmed option turned on, please make sure it's turned off.
That solved the problem! Using a CS-580, I had turned the "Private Call Acknowledged" on. After unchecking it, the BM 9990 Parrot works perfectly. Thanks!
K5BOU
Posts: 4
Joined: Sun Nov 15, 2020 4:17 pm

Re: Parrot not working

Post by K5BOU »

HA2NON wrote: Wed Jun 14, 2017 7:37 am openSPOT's all service DMR IDs work both as a private and group call, so the issue is with your radio's configuration. I think you have the private call confirmed option turned on, please make sure it's turned off.
Hi, how you turn on? i use FT 991 A
Post Reply