Experimental BS mode NOT sending any idle frames after CSBK RX.

Post Reply
User avatar
n8lbv
Posts: 62
Joined: Sun Apr 08, 2018 4:47 pm

Experimental BS mode NOT sending any idle frames after CSBK RX.

Post by n8lbv » Thu Dec 06, 2018 5:05 am

I am testing this and am not getting the expected result.
Openspot TX: 443.1125
Openspot RX: 448.1125

Radio TX: 448.1125
Radio RX: 443.1125

When initiating communication from radio to Openspot in BS mode
Openspot never "sends a few idle frames on both timeslots
As is described and radio just gives A failure indication as a result of not getting and idle frames back.
Can see clearly on Hostspot it is not transmitting anything upon RX of CSBK.



For the DMR/BS mode to work correctly, you have to set separate RX and TX frequencies both for openSPOT and your transceiver. As openSPOT only has one modem it is not capable of full duplex operation, it can only receive or only transmit at a time. Therefore, the difference between RX and TX frequencies doesn’t matter. [[[[When openSPOT receives a BS Outbound Activation CSBK frame, it will send a few idle frames on both timeslots,]]]
I feel more like I do now.

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 3439
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Experimental BS mode NOT sending any idle frames after CSBK RX.

Post by HA2NON » Thu Dec 06, 2018 6:20 am

This can be because the openSPOT was not able to receive the BS outbound activation correctly. This can happen, that's why this mode is marked as experimental.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

User avatar
n8lbv
Posts: 62
Joined: Sun Apr 08, 2018 4:47 pm

Re: Experimental BS mode NOT sending any idle frames after CSBK RX.

Post by n8lbv » Thu Dec 06, 2018 3:20 pm

Thanks for the reply.
Do you have any experience why it would not be able to "receive the BS outbound activation correctly"
Is this a shortcoming of the openspot? or a work that was never finished?
I'm interested in experimenting but am not sure what to test next.
I'd expect the openspot should RX the BS outbound activation correctly

Unless this functionality was never implemented even if experimental.

Thanks.
I feel more like I do now.

User avatar
n8lbv
Posts: 62
Joined: Sun Apr 08, 2018 4:47 pm

Re: Experimental BS mode NOT sending any idle frames after CSBK RX.

Post by n8lbv » Thu Dec 27, 2018 7:25 am

I'd like to experiment.
Can you please share some ideas and thoughts as to what I can try, what has been tried?
Does it work at all in some cases?
Can you please share some information?

Thanks.
I feel more like I do now.

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 3439
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Experimental BS mode NOT sending any idle frames after CSBK RX.

Post by HA2NON » Thu Dec 27, 2018 9:22 am

We've experimented it during development of the openSPOT back in 2015 and left the option there for other users to experiment. I don't remember what the final results were as it was a while ago.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

Post Reply