Openspot Transmits to BM but No RX Audio

dmrlobotomy
Posts: 20
Joined: Wed Oct 05, 2016 9:00 pm

Re: Openspot Transmits to BM but No RX Audio

Post by dmrlobotomy »

Ran now on 3116, 3106 and 3100/4639 with TG 9 added to the RX Group List with Auto connect 0 / Private call and this is successful in all three cases.

I've done this on two of the three OpenSpot and the same code plug on two MD-380 radios and this was successful on both OpenSpot units and MD380 radios.

So the updated work around is to add TG 9 to the receiver group in the MD-380 code plug for each channel / TG used with the open spot.

dmrlobotomy
Posts: 20
Joined: Wed Oct 05, 2016 9:00 pm

Re: Openspot Transmits to BM but No RX Audio

Post by dmrlobotomy »

And, of course, we have to now listen to TG 9 traffic to use the OpenSpot on other TGs.

I hope this is useful toward resolving this and providing a temporary work around for other users.

Please let me know if you need anything additional testing and/or data collection...

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5155
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Openspot Transmits to BM but No RX Audio

Post by HA2NON »

Ok, that's why I asked if you are using rerouting. :)

Seems like you have enabled rerouting (rerouting is set to 3116). This behavior of your openSPOT is not a bug then, it's a feature. When using rerouting, all calls coming from the reroute ID (3116) will be rerouted to TG9, and all calls going from your radio to TG9 are rerouted to 3116. So you need to have TG9 in your RX group list if reroute is enabled.

The reroute feature is there because if you use it, you don't have to deal with the RX group list, you only have to add TG9 there and that's all, because all calls will come to TG9 on your radio, you talk to there and openSPOT will forward the TG9 call to the talkgroup/reflector you set to reroute.

I hope this helps understanding the feature.

If you want the "normal" behavior, set Reroute ID to 0.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

dmrlobotomy
Posts: 20
Joined: Wed Oct 05, 2016 9:00 pm

Re: Openspot Transmits to BM but No RX Audio

Post by dmrlobotomy »

OK. But I never turned on rerouting so this apparently was on by default (this is true of all three units I've looked at). That is probably going to result in a lot of headaches for you...

dmrlobotomy
Posts: 20
Joined: Wed Oct 05, 2016 9:00 pm

Re: Openspot Transmits to BM but No RX Audio

Post by dmrlobotomy »

I've confirmed that turning off forwarding and removing TG9 from the radio's RX group results in proper operation.

The manual implies that this option is not enabled by default in that the wording indicates that the user can enable this option. I'd recommend that either the device be shipped with this off by default, or clearly document, in the manual, that this is on by default and needs to be turned off if user doesn't want to include TG 9 in the RX groups in their code plug.

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5155
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Openspot Transmits to BM but No RX Audio

Post by HA2NON »

I've found out now that turning on auto connect automatically turns on rerouting, which is a bug, and will be fixed. Thanks for the notice!
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

dmrlobotomy
Posts: 20
Joined: Wed Oct 05, 2016 9:00 pm

Re: Openspot Transmits to BM but No RX Audio

Post by dmrlobotomy »

Outstanding! Thanks much!!!!

F5AHO
Posts: 1
Joined: Wed Aug 17, 2016 7:15 pm

Re: Openspot Transmits to BM but No RX Audio

Post by F5AHO »

Hello,
I had the same problem and after writting 0 (zero) in "connectors\Reroute DMR TG9 calls to ID (0 to disable) " in advanced mode all is OK.
73
Jean-Pierre F5AHO

flyboybobio
Posts: 10
Joined: Mon Oct 03, 2016 12:00 am
Location: CM88OM

Re: Openspot Transmits to BM but No RX Audio

Post by flyboybobio »

Having similar issues with a Motorola XPR6550 DMR radio. Just upgraded to Beta ver 70 firmware and when I try to auto connect to a particular Brandmister talk group it reroutes me to TG9 ID 99. When will a new FW be released to correct this issue. What a headache. I thought DV4Mini was confusing.

Bob KC6SOT

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5155
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Openspot Transmits to BM but No RX Audio

Post by HA2NON »

Bob, just turn off rerouting, if it confuses you.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

Post Reply