Openspot2 - wifi not connecting to

kd2pm
Posts: 80
Joined: Thu Jan 31, 2019 11:18 am
Location: East Windsor NJ

Re: Openspot2 - wifi not connecting to

Post by kd2pm »

I updated to beta 30 and still no luck. Mikrotik is stating "unicast key exchange timeout"

I have it set to both WPA and WPA2 and just using aes-ccm. I even tried with tkip on as well.

Seems I will have to pull out the other AP I have and try that and if that works...I dont know if its an OS2 or Mikrotik issue...
Ed Velez
KD2PM
East Windsor, NJ, USA
Alinco DJ-MD5TGP / Anytone AT-D878UV
Zumspot-PiZero / SharkRF OpenSpot2
kd2pm
Posts: 80
Joined: Thu Jan 31, 2019 11:18 am
Location: East Windsor NJ

Re: Openspot2 - wifi not connecting to

Post by kd2pm »

Looks like I have the problem solved. Had 2 issues.
1. Having 2 mikrotiks back to back (2 different floors in my house) and one being dhcp, the dhcp relay was not working correctly. Something in the config would not allow DHCP assignment to the OS2, yet all the other devices could get an IP address.
2. Would also appear that the OS2 was not overly happy with my IP range I use in my home. Instead of the typical 192.168 that comes with almost every router, I changed mine to 172.16 and that seemed to be an issue getting the OS2 on the network.

I took out one of the MT routers and also reset the config on the other MT. Seems it will connect practically every time now.

I am going to do some testing via sercon to change the SSID and KEY and have it move from AP to AP to see that it no longer has a problem with the handshaking and getting an assigned IP address.
Ed Velez
KD2PM
East Windsor, NJ, USA
Alinco DJ-MD5TGP / Anytone AT-D878UV
Zumspot-PiZero / SharkRF OpenSpot2
Post Reply