openspot2 keyless entry interference

Post Reply
Zurich
Posts: 1
Joined: Sun Mar 22, 2020 5:26 pm

openspot2 keyless entry interference

Post by Zurich »

Had trouble getting a hotspot working in my 2019 Subaru Forester. No luck with the cheap pi configuration, so tried with the openspot2 ( pi version would not connect to my iPhone hotspot reliably but openspot2 works great with the iPhone).

Had my hotspot connection ( usb power outlet always powered on, same power run to my mobile rig ), so the openspot2 was always powered on, even without ignition on. One day I placed the openspot2 in the cubby hole in front of the shifter, and went to start the car.
Got an error on the dashboard that no key fob was detected and car would not lock, unlock or start.

When I unplugged the openspot2 power all key fob functions work. So there must be some interference from the openspot ( or maybe any other hotspot ) and the keyless entry.

Switching openspot2 power to the car USB port ( on only when ignition is on ), and keeping the openspot away from the dashboard ( near the back of the driver seat ) is my current configuration and have had not further problems for the last month.

hope this helps.
Tyrbiter
Posts: 653
Joined: Thu Dec 22, 2016 11:25 pm

Re: openspot2 keyless entry interference

Post by Tyrbiter »

This is a common problem because of the limited range of frequencies used for LPDs in the EU, some countries started with only a spot frequency at 433.92MHz and that is one of the most used. Combine this with the poor performance of the super-regen receivers used it leads to a lot of interference.

I would suggest changing the frequency that the openSPOT2 is using to be at least 1MHz away from the keyless entry system, that could be anywhere from 433.05-434.79 MHz, but they often have a 600kHz IF which needs to be added to that exclusion zone.

Also note that 435-438MHz should be avoided as it is the satellite band.
Brian G8SEZ
Post Reply