Openspot2 - wifi not connecting to

9g5ar
Posts: 15
Joined: Thu Dec 27, 2018 10:04 pm

Re: Openspot2 - wifi not connecting to

Post by 9g5ar »

I' performed the factory reset,
.....( hardware button depressed for 30+ secs)

All configuration was wiped out.
The initial setup screen came up when I logged into the device.

I then tried to connect to my wifi.... did not work.

only worked when I disabled security on my wifi router.

User avatar
HA5OGR
Posts: 508
Joined: Sat Mar 26, 2016 7:32 pm
Location: Dunavarsány
Contact:

Re: Openspot2 - wifi not connecting to

Post by HA5OGR »

Enable WPS (WI-FI Protected Setup) option in router menu.
73 de Lajos
Openspot alpha tester
Image

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5286
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Openspot2 - wifi not connecting to

Post by HA2NON »

Please make sure the country of operation is set correctly in the openSPOT2. If you use China then the openSPOT2 will only allow channels 1 to 11. Make sure the openSPOT2 is upgraded to the latest stable firmware version v24. Make sure you enter the Wi-Fi password case sensitive. What LED color do you get when the openSPOT2 is trying to connect?
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

9g5ar
Posts: 15
Joined: Thu Dec 27, 2018 10:04 pm

Re: Openspot2 - wifi not connecting to

Post by 9g5ar »

HA2NON wrote: Please make sure the country of operation is set correctly in the openSPOT2.

Done !
HA2NON wrote: Make sure the openSPOT2 is upgraded to the latest stable firmware version v24.

After thorough testing on v24 stable, I upgraded to v26 beta.
HA2NON wrote: Make sure you enter the Wi-Fi password case sensitive.

Done !
HA2NON wrote: What LED color do you get when the openSPOT2 is trying to connect?
Blue and Red with audio message.....
"Openspot trying to connect wifi Network" on phone ( th-d72A)


If you read my last post, you'll see I "factory reset" the openspot2 (v26 beta) and with no other configuration set up, could not get wifi to connect (unless security is disabled) .
Same with v24 stable.

I have the exact same setup (wifi Access Point on Note4/Note5) that openspot2 connects to with no issues.

9g5ar
Posts: 15
Joined: Thu Dec 27, 2018 10:04 pm

Re: Openspot2 - wifi not connecting to

Post by 9g5ar »

Looks like the openspot2 has unresolved wifi issues !!!

User avatar
HA5OGR
Posts: 508
Joined: Sat Mar 26, 2016 7:32 pm
Location: Dunavarsány
Contact:

Re: Openspot2 - wifi not connecting to

Post by HA5OGR »

Did you tried the WPS (WI-FI Protected Setup) function in router menu? Manual says "The WPS function can be used only when the security mode of the wireless network is set to WPA-PSK, WPA2-PSK, or WPA-PSK/WPA2-PSK, and the SSID is set to SSID1. It is recommended that you set the security mode to WPA-PSK/WPA2-PSK". Are you sure you have typed WIFI password correct? How many characters the WIFI password and does it contain special characters?
73 de Lajos
Openspot alpha tester
Image

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 5286
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: Openspot2 - wifi not connecting to

Post by HA2NON »

9g5ar wrote:
Tue Jan 22, 2019 5:25 am
Looks like the openspot2 has unresolved wifi issues !!!
Please keep in mind that you wrote the openSPOT2 works perfectly with your other devices. Try changing Wi-Fi channels on your router, or try changing the channel bandwidth, or other settings. Have you tried using another router?
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

9g5ar
Posts: 15
Joined: Thu Dec 27, 2018 10:04 pm

Re: Openspot2 - wifi not connecting to

Post by 9g5ar »

Update:

Now on v29 beta. ( not sure when the updates occurred ).
Last manual update was from v26 stable to v27beta

Connection to my Home wifi is working !!

User avatar
HA5OGR
Posts: 508
Joined: Sat Mar 26, 2016 7:32 pm
Location: Dunavarsány
Contact:

Re: Openspot2 - wifi not connecting to

Post by HA5OGR »

If there is an update available and you selected this option by default at 04:00 am.
73 de Lajos
Openspot alpha tester
Image

kd2pm
Posts: 80
Joined: Thu Jan 31, 2019 11:18 am
Location: East Windsor NJ

Re: Openspot2 - wifi not connecting to

Post by kd2pm »

9g5ar wrote:
Tue Jan 29, 2019 10:48 am
Update:

Now on v29 beta. ( not sure when the updates occurred ).
Last manual update was from v26 stable to v27beta

Connection to my Home wifi is working !!
I may have to go the same route as you did going to beta 29. I am using stable 24 and the OS2 will NOT connect to either of my Mikrotik devices yet it will connect to my Samsung S8+ and also a Linksys router in the office. Everything else in my house including NEST, internet radio, PC's etc all have no issue connecting to my Mikrotiks. I do have a spare D-Link AP floating around I could also try to connect into my home network to see if the OS2 will connect to that without any issues.

My 2 routers are using US channels 1 and 6, I have WPA and WPA2 on with TKIP and AES enabled. I have the mode on them set to G/N but I could set them to B/G/N if need be.

What I see in my logs is that it tries to connect but never gets an IP address and so it associates and a couple seconds later disassociates and keeps going back and forth.
Ed Velez
KD2PM
East Windsor, NJ, USA
Alinco DJ-MD5TGP / Anytone AT-D878UV
Zumspot-PiZero / SharkRF OpenSpot2

Post Reply