WiFi problem with Huawei E5885

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 4262
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: WiFi problem with Huawei E5885

Post by HA2NON » Thu Jun 20, 2019 10:39 am

Try enabling DNS server override on the OS2's Network page, IP settings to make the OS2 use 8.8.8.8 as the DNS server instead of the router's DNS server.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

OZ9KL
Posts: 79
Joined: Thu Apr 27, 2017 6:18 am

Re: WiFi problem with Huawei E5885

Post by OZ9KL » Thu Jun 20, 2019 12:26 pm

Hi HA2NON.

I have already tried that, as I wrote in one of my first post about this problem:

Re: WiFi problem with Huawei E5885
Post by OZ9KL » Sat Mar 30, 2019 8:57 am

Hi HA2NON

I have tried to connect to the Huawei E5885 again, and still don't succeed. This time OP2 actually stays connected, but as I see it, it have some problem to resolve adresses. I have also tried to override DNS adresses in the network configuration with the DNS server from Google. Still same error.

bholmer
Posts: 3
Joined: Thu Jun 20, 2019 7:21 am

Re: WiFi problem with Huawei E5885

Post by bholmer » Wed Jun 26, 2019 6:39 am

I now used the combination OS2 and 5885 for some days during my travel to the HamRadio Exhibition in Friedrichshafen. Everything worked fine as long as I switch the Huawei to WEP encryption.

So I would suggest that the bug is somewhere in a layer handling the WPA2 encryption/decryption below IP Level so that the OS2 cannot issue DNS requests to the Huawei or the Internet. The OS2 is not reachable in the Huawei subnet at all from a client in the same Subnet.

Danie
Posts: 3
Joined: Sat Jul 27, 2019 8:54 pm

Re: WiFi problem with Huawei E5885

Post by Danie » Sat Jul 27, 2019 9:04 pm

I've been having the same problem with OS2 and my Huawei E5885 hotspot so seems this is a general issue. I used to have a similar problem with a brand new Netgear hotspot and Waze navigation - after buying the E5885 Waze and everything worked 100% except now the problem with the E5885. Real pity as its a great hotspot but switching to WEP is a worry from a security perspective.

But the good thing is that at least now we have an idea what setting has been causing the problem.

bholmer
Posts: 3
Joined: Thu Jun 20, 2019 7:21 am

Re: WiFi problem with Huawei E5885

Post by bholmer » Fri Aug 02, 2019 2:49 pm

Are there any news regarding this issue with the Huawei hotspot?

As all other clients I have work fine with the Huawei hotpot and I doubt that Huawei proceeds and fixes their firmware to make it OS2 compatible I would really appreciate if SharkRF tries to analyze the bug in their firmware.

I really dont want to leave the E5885 on WEP-encryption too Long.

Bert DL9BBH

Danie
Posts: 3
Joined: Sat Jul 27, 2019 8:54 pm

Re: WiFi problem with Huawei E5885

Post by Danie » Sat Aug 17, 2019 11:10 am

Any solution yet?

The WEP workaround works perfectly for me but it is not secure. All my other devices (various phones, laptops, tablets) are all connecting fine the hotspot with WPA.

User avatar
DM4ZZ
Posts: 6
Joined: Wed Oct 31, 2018 4:31 pm
Location: Heppenheim

Re: WiFi problem with Huawei E5885

Post by DM4ZZ » Fri Oct 11, 2019 2:45 am

Danie wrote:
Sat Aug 17, 2019 11:10 am
Any solution yet?

The WEP workaround works perfectly for me but it is not secure. All my other devices (various phones, laptops, tablets) are all connecting fine the hotspot with WPA.
now we received this great hotspot and found out that we are facing the same problems because we both use the E5885 for connecting to the mobile network.

is there any change / solution to get it working with WPA2 ?
---
73 de Ben, DM4ZZ

Danie
Posts: 3
Joined: Sat Jul 27, 2019 8:54 pm

Re: WiFi problem with Huawei E5885

Post by Danie » Fri Oct 11, 2019 7:25 pm

I'm beginning to think the E5885 has some problem as mine was also not connecting with Echolink. Went back to my Netgear hotspot which I ditched as it was not connecting with Waze, and thought I'd check the Wifi channel number. The Netgear was defaulting to a non-standard Wifi channel above 11. I forced it to use channel 6 and it now works with Waze, the Openspot2, and Echolink.

Odd issue, but maybe we must look at WiFi channel numbers possibly with the E5885 too.

Post Reply