No Password Prompt in AP Mode

ki5sie-os
Posts: 3
Joined: Tue Feb 11, 2020 5:56 pm

Re: No Password Prompt in AP Mode

Post by ki5sie-os »

Im having the same issue. I think i have been able to identify how to replicate a bit more.

What I am seeing. Is that when the security setting is set for the OpenSpot to where it is configured with a password. Then AP mode on the OpenSpot no longer allows you to access it or it does not provide a password prompt and instead only gives the status page.

What I am attempting to do is use my already configured openspot, but to where I am moving it to a different SSID. This is where i would think i would hold down the reset button for 3 seconds to trigger the AP, then login to the AP, and configure the OS to the new SSID. This is not accomplishable once the radio is setup "securely". Right now, the only solution is to make sure that the openspot is on a wifi network it has already established a relationship with and enter it though its interface on that network. This means that before you jump off your last good connected network, you must go into the openspot and remove the security setting that gives the openspot a password so that its AP interface is available when you are attempting to join the next wireless network.

For me, i am usually forgetting to do this last step of removing the password protection of the openspot before i unplug it and move it to the next wireless hotspot. This is causing me to having to perform a factory reset on the device each time i move its wireless network. Not having the device password protected is not an option even though its transmission is broadcasted in clear text and can be intercepted by anyone sniffing the network if they are in a position to do so.

Any tips or solutions for this? Thank you in advance.

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 4673
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: No Password Prompt in AP Mode

Post by HA2NON »

In summary, do you mean that if you set a web int. password on the Network page, Network settings section, then the web interface can't be opened in AP mode?
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

ki5sie-os
Posts: 3
Joined: Tue Feb 11, 2020 5:56 pm

Re: No Password Prompt in AP Mode

Post by ki5sie-os »

Yes. In Summary, that is what I am experiencing.
Once a PW is supplied as a setting it appears it only prompts you on the internal network the OS is configured to, and does not provide a prompt in AP mode. Ive attempted to force browse to pages like login, but they immediately redirect to the AP status page like described in the previous comments.

I would think the AP mode Interface would allow you to supply the same password, or not require one, even if set on the other interface. I personally could not care if a PW is required in AP mode as you have to physically place it in AP mode and access to the physical hardware is required. I could see how this would add additional security risks. This is also being understanding of what little protection the password protection provides being it is over an unencrypted connection. Either way, it being enabled, kills the ability to enter into the device through AP mode.

There is some business justification on the fact that I must have the device set with a password in order to be on the network i have it on, this is the reason for using it.

User avatar
HA2NON
SharkRF team
SharkRF team
Posts: 4673
Joined: Fri Mar 25, 2016 3:33 pm
Contact:

Re: No Password Prompt in AP Mode

Post by HA2NON »

Issue has been reproduced successfully, thanks for reporting. Fix will be available in the next beta firmware.
Norbert "Nonoo" Varga, HA2NON
SharkRF Team

ki5sie-os
Posts: 3
Joined: Tue Feb 11, 2020 5:56 pm

Re: No Password Prompt in AP Mode

Post by ki5sie-os »

Awesome. Im glad that it is an issue that can be reproduced. I am looking forward to the fix.

Thanks for all the support.

Edit: I went in and downloaded the beta firmware and have verified that I am no longer experiencing any issues. This appears to be resolved on my end. Thank you again.

Post Reply