Rebooting randomly

vk4nsp
Posts: 22
Joined: Wed Jun 12, 2019 7:27 am
Location: Rockhampton, Australia

Rebooting randomly

Post by vk4nsp »

Hi,

My Openspot 3 has had the problem for awhile again, LED goes orange and after about 15secs it reboots. This happens at random times changing connectors and settings from the webserver. I have also had it crash in the middle of txing.

I have done a reset same issue

Not sure if I have to do a manual reinstall of the firmware again or if it's hardware issue

Regards,
Shaun VK4NSP
Tyrbiter
Posts: 842
Joined: Thu Dec 22, 2016 11:25 pm

Re: Rebooting randomly

Post by Tyrbiter »

I would suggest requesting the latest firmware from info@sharkrf.com and reloading it, there are ways in which the flash storage could have become corrupted even if the culprit was a stray cosmic ray.

Probably sensible to save the configuration then perform a full reset before and after loading the firmware again. If that doesn't fix it then let us know.
Brian G8SEZ
vk4nsp
Posts: 22
Joined: Wed Jun 12, 2019 7:27 am
Location: Rockhampton, Australia

Re: Rebooting randomly

Post by vk4nsp »

Thanks

I have received the file from Norbert and have reinstalled, so far so good

Regards,
Shaun VK4NSP
vk4nsp
Posts: 22
Joined: Wed Jun 12, 2019 7:27 am
Location: Rockhampton, Australia

Re: Rebooting randomly

Post by vk4nsp »

It's having trouble downloading the callsign database

Any issues? it started and started again and now stuck at 0%. Atleast it hasn't rebooted

Regards,
Shaun VK4NSP
vk4nsp
Posts: 22
Joined: Wed Jun 12, 2019 7:27 am
Location: Rockhampton, Australia

Re: Rebooting randomly

Post by vk4nsp »

Did a forced reboot now downloading ok

See how it goes

Regards,
Shaun VKNSP
vk4nsp
Posts: 22
Joined: Wed Jun 12, 2019 7:27 am
Location: Rockhampton, Australia

Re: Rebooting randomly

Post by vk4nsp »

Still got the same problem, LED goes yellow for a short time reboots, audio comes up with profile 1 ready and connects back to the mode you were using. It normally happens when changing settings on the webserver and sometimes when TXing. It started since going to v54 beta.

Starting to get very annoying on a product that cost a bit of money.

Regards,
Shaun VK4NSP
vk4nsp
Posts: 22
Joined: Wed Jun 12, 2019 7:27 am
Location: Rockhampton, Australia

Re: Rebooting randomly

Post by vk4nsp »

I just tried to TX on DSTAR and it rebooted after I finished my over on the radio, the log came up with this over and over again before it rebooted

21:26:02 a3k-receive: tc queue malloc err
Tyrbiter
Posts: 842
Joined: Thu Dec 22, 2016 11:25 pm

Re: Rebooting randomly

Post by Tyrbiter »

Did you do a full reset before and after loading the firmware via USB?
Brian G8SEZ
vk4nsp
Posts: 22
Joined: Wed Jun 12, 2019 7:27 am
Location: Rockhampton, Australia

Re: Rebooting randomly

Post by vk4nsp »

Yes I did

A bit more from the log

21:26:03 a3k-receive: init ok
21:26:03 ref: got ping, replying
21:26:04 a3k-receive: tc queue malloc err
21:26:04 a3k-receive: tc queue malloc err
21:26:04 a3k-receive: tc queue malloc err
21:26:04 net: enet link down
21:26:04 a3k-receive: tc queue malloc err
21:26:04 a3k-receive: tc queue malloc err
21:26:04 a3k-receive: tc queue malloc err
21:26:04 a3k-receive: tc queue malloc err
21:26:04 a3k-receive: tc queue malloc err
21:26:04 a3k-receive: tc queue malloc err
21:26:04 a3k-receive: tc queue malloc err
21:26:05 a3k-receive: tc queue malloc err
21:26:05 a3k-receive: tc queue malloc err
21:26:05 ref: ping send error
21:26:05 ref: init reconnect
21:26:05 spk: starting voice announcement
vk4nsp
Posts: 22
Joined: Wed Jun 12, 2019 7:27 am
Location: Rockhampton, Australia

Re: Rebooting randomly

Post by vk4nsp »

I was going to see if going back to V53 fixes it as it all started from V54 for me. I know support said there was nothing added to v54, just sounds a bit strange.

It's really making it unusable for me

Regards,
Shaun
Post Reply